burpsuite升级遇到的问题

我听着那少年的声音

在还有未来的过去

渴望着 美好结局

却没能成为自己

burp之前用的1.7.x版本都没什么问题,最近整理文件想更新一下bp最新版,就在吾爱上找到2.8的版本,但是是没法使用的,磨叽一下午后终于解决了。

成因:

bp2.0.x以及以下的版本需要的环境是JAVA8.0

bp2.1.x以后的版本需要的Java环境要大于8.0

然后我更新Java后,BurpSuiteLoader提供的linces key总是无法通过。

中间遇到乱七八糟的Java异常报错不提,问题的成因在于,之前Java8的内容没有完全卸载。

不仅仅是在windows下的卸载软件中卸载Java8,还需要你在system或者system64目录下删除如下文件:

javaw.exe、java.exe

但是我的电脑目录下无这两个文件,然后检查环境变量,也没有多余的Java环境。

于是使用命令

where java

居然找到了两条Java的环境变量位置,顺着第一条环境变量的路径,果然找到了要删除的那几个exe文件,删除后顺利启动burpsuite。

坚持原创技术分享,您的支持将鼓励我继续创作!
------ 本文结束 ------

版权声明

LangZi_Blog's by Jy Xie is licensed under a Creative Commons BY-NC-ND 4.0 International License
由浪子LangZi创作并维护的Langzi_Blog's博客采用创作共用保留署名-非商业-禁止演绎4.0国际许可证
本文首发于Langzi_Blog's 博客( http://langzi.fun ),版权所有,侵权必究。

0%